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Software License Agreement

1. Usage rights

Anritsu Meter grants the purchaser of the aforementioned Anritsu Meter software

a non-transferable, non-exclusive right to use the programs included in it and its

related materials (hereafter referred to as the “Software”) in the manner described

below, and not the right to sell it.

The purchaser can produce only one duplicate of the Software for backup
purposes.

The Software can be installed for use in only one specified computer (hereafter
referred to as the “Computer”). The purchaser is not granted the right to install
or call up the Software in or from another computer such as a workstation,
terminal, or electronic device (hereafter referred to collectively as a “Device”).

2. Ownership of the rights

The intangible property rights, including the copyrights to the Software and the

software duplicated from it for backup purposes, belong to Anritsu Meter and the

suppliers to Anritsu Meter. The Software is protected under copyright laws and
international conventions.
3. Guarantee

(1) Anritsu Meter guarantees the purchaser that the recorded/stored media
containing the Software itself, and the condition of the Software recorded on it
are free of defects inherent in the material of the media or those attributable to
manufacturing for a period of 90 days after the Software was purchased. If
within this guarantee period the recorded/stored media of the Software itself or
the condition of the Software recorded on it is found to have material or
manufacturing defects, the media in which the Software is recorded/stored will
be changed for a new one, on condition that Anritsu Meter is notified of said
defects within the guarantee period by the purchaser.

(2) Except for the replacement of the recorded/stored media of the Software
mentioned above, Anritsu Meter does not provide the purchaser with any
guarantee for the Software, whether explicit or implicit, and grants the
purchaser use of the Software in only the state in which it was supplied.
Anritsu Meter does not guarantee that the Software is appropriate or useful for
the specific purposes of use intended by the purchaser, nor does Anritsu Meter
guarantee that the Software will not be interrupted during execution and that
it will be executed error-free.

(3) The responsibility of Anritsu Meter under this article solely lies with the
recording state of the Software, and Anritsu Meter does not assume any
responsibility for any explicit or implicit guarantees under other laws,
including responsibility for any defects, as well as for the purchaser’s lost
profits arising from use of the Software, losses incurred for special reasons,
damage to data, etc., and compensation for losses or damage to the intangible
property rights arising from claims from third parties.



4. Obligations of the purchaser

The purchaser is required to take notice that the Software contains confidential

information or property information, including intangible property rights protected

under copyright laws, and not to perform the acts listed below:

(1) The act of using or duplicating the Software under other than the conditions
stipulated in this agreement.

(2) The act of modifying, reverse-engineering, decompiling, or disassembling the
Software.

(3) The act of using the Software in multiple devices after separating it into its
constituent parts. This is because the Software is provided as one integral
product.

(4) The act of transferring, lending, granting use, or granting reuse of the Software
to third parties. However, if the purchaser is engaged in a lending business and
purchased the Software for that purpose, the purchaser will be approved of the
above act as a special case.

(5) The act of violating the limitations imposed on special font usage (font
copyright) owned by the rightful claimant.

5. Termination of the usage rights

(1) The purchaser may terminate the rights to use the Software at any time.

(2) If the purchaser violates the conditions stipulated in this agreement, the rights
to use the Software are automatically terminated.

6. Measures taken upon termination of the usage rights

(1) When the purchaser has lost the rights to use the Software, the purchaser shall
erase or destroy all of the Software and its duplicate.

(2) When the purchaser has lost the rights to use the Software, the purchaser shall
erase or destroy all of the Software and its duplicate, except where the
purchaser acquired the Software as an upgrade version, in which case the
media on which the earlier version of the Software is recorded need not be
destroyed.

7. Miscellaneous rules

(1) This agreement is intended to be compliant with Japanese laws.

(2) If the Software falls under the application of Japanese foreign exchange or
foreign trade laws or the regulations ancillary thereto or the United States
export restraint or control regulations, the purchaser shall observe said laws
and regulations.
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1.

Overview

AMS-850 is the software that allows you to download data from the Compact
Thermo Logger, easily create graphs, tables, or CSV files, and print the data. The
following operating environment is needed to use this software.

OS : Microsoft Windows 7
Microsoft Windows 8.1
Microsoft Windows 10
Requires a PC of specifications sufficient to run the above operating systems.

All PCs under the recommended environment are not guaranteed to work
successfully with AMS-850.

AMS-850 can be used only by the user that has a system administrative right
(Administrator).

AMS-850 does not support Mac OS.

Microsoft® Windows® 7, Windows® 8.1, Windows® 10 are registered trademarks of
Microsoft Corporation in the United States and other countries.



2. Simple Guide to Operation

@ Upon first use of AMS-850 (installation)

(1) Turn on the power to the measuring instrument and set the CD-ROM in your
computer.

(2) Install AMS-850.

(3) Connect the measuring instrument to the computer with the communication
cable.

(4) Launch AMS-850 and set up the communication port.
* For details, refer to Chapter 4, “Installation.”

® To download the data saved in the measuring instrument

(1) Connect the measuring instrument to the computer with the communication
cable.

(2) Turn on the power to the measuring instrument.

(3) Launch AMS-850 and choose Input data from the Communication menu.

(4) Specify the destination folder in which to save the data.
* For details, refer to Section 6.3, “Downloading Data from the Measuring

Instrument.”

® To display the data contained in a file
(1) Choose Open from the File menu.
(2) Specify a file name to open.
(3) In the View menu, you can choose between Display the Graph and Display the
data list display.
* For details, refer to Section 6.5, “Loading and Displaying an Existing File.”

® To open a saved file in Excel
(1) Choose Create Text file from the File menu.
(2) Specify a file name.
(3) Specify the range of data you wish to be converted into a CSV file and click OK.
A text file will be created, which can then be opened in Excel.
* For details, refer to Section 6.9, “Using Data in Spreadsheet Software.”

® To draw a graph in real time

(1) Connect the measuring instrument to the computer with the communication
cable.

(2) Turn on the power to the measuring instrument.

(3) Choose Remote setting from the Communication menu.

(4) Set the timing with which to obtain data, and other measurement parameters
here.

(5) Choose Set Real-time data autosaving from the Settings menu and then set the
destination folder in which to save files and other items.

(6) Choose Real Measurement from the Communication menu.



(7) Specify the destination folder in which to save data.
(8) Set the vertical and horizontal axes of a graph and other items.
* For details, refer to Section 6.4, “Making Real Measurement Method.”



3. Connecting the Measuring Instrument
3.1 When Using RS-232C Cable for connection
For connection to the PC side, plug the RS-232C cable into the connector marked

with |%|0r||@|0||.

AMOTH Fi-2000 D ANRITSU METER CO,LTD.
FTBEROPTIC THERMOMETER

SENSOR

CAUTION
If the measuring instrument does not need to communicate with the PC, be sure
to isolate it from the PC (by removing the communication cable). If the measuring
instrument remains connected to the PC while you run other software
applications on the PC, the measuring instrument may operate erratically or
malfunction.

3.2 PC without a RS-232C port
If your PC is not equipped with a ‘% |or‘ | OO ‘connector, use the provided
USB-RS232C converter.
Read the user’s manual for the provided USB-RS232C converter. Follow the
Instructions in the manual to connect the converter to your PC, and then use the
dedicated FL-2000 cable to connect the FL-2000.

converter




4. Installation
Close all of the currently active software applications. AMS-850 may not be installed
correctly if another software application is running.
4.1 Installing AMS-850
(1) Set the AMS-850 CD-ROM into the CD-ROM drive of your computer.
After a few moments, the [Install Program] window opens.
% If the window does not open automatically, select My Computer on the
Desktop and then double-click the CD-ROM icon.

(3) Microsoft .NET Framework 4 is required on your computer to work the

AMS-850.
If it is not installed on your computer, Setup screen is displayed.
Read the contents, click [Accept] if there is no problem.

L AMS-830 Setup (==

For the following components:

Microsoft NET Framework 4 Glient Profile (x86 and x64)

Pleaze read the following license agreement. Press the page down key to see
the rest of the agreement.

MICROSOFT SOFTWARE
SUPPLEMENTAL LICENSE TERMS

MICROSOFT .NET FRAMEWORK 4 FOR MICROSOFT
WINDOWS OPERATING SYSTEM il

EI Wiew EULA for printing

Do you accept the terms of the pendine License Agreement?

If wou chooze Don't Accept, install will cloze. To install vou must accept this
agreement.

fccept | [ Don't ficcept




Click [Yes] .

P "

@ User Account Control @

((j‘] Do you want to allow the following program to make

<’ changes to this computer?

% Program name:  dotMetFxd0_Client_x86_x04.exe
Verified publisher: Microsoft Corporation
File origin: Hard drive on this computer

(v) Show details Y || Mo |

Change when these notifications appear

Setup starts.

‘L) AMS-850 Setup ==

-j Ihstalling Microsoft MET Framework 4 Glient Profile (<86 and =64)..

Cancel

Restart when finished.

‘L) AMS-850 Setup 23w

-'j Setup must reboot before proceeding.

Thoosze “es' to reboot now or ‘Mo’ to manually reboot later.

Details 5> | Yes ] [ Mo




(4) Follow the instructions to complete the installation.

(15 AMs-850 o] @ [
Welcome to the AMS-850 Setup Wizard LA

|
-

The inztaller will guide pou through the steps required to install Ak 5 -850 on your computer.

WARMIMNG: Thiz computer program iz pratected by copyright law and international treaties.
Inauthorized duplication or distribution of thiz pragram, or any portion of it, may result in severe civil
or criminal penalties, and will be prozecuted to the maximum extent pogzible under the law.

[ 1) Ams-850 o] B (=]
Select Installation Folder |—

The inztaller will inztall AMS-850 to the following folder.

To inztall in this folder, click "Me=t". To install to a different folder. enter it below or click “Browse".

Folder:
C:¥Program Files (x86)%Anr itzuMeter¥ 4ME-050¥ | Erowse... |
| DiskCost. |
Inztall AMS-850 for vourzelf, or for anvone who uses thiz computer:
@ Everyone
Just me
Cancel | | < Back | [ Mext >




'ﬁ! AMS-850

Confirm Installation

The ingtaller iz ready ta install Ak 5-850 on pour computer.

Click “"Mext" to start the installation.

Cancel ] [ < Back

] [ Newt>

Click [Yes] .

@ User Account Control

e,

o)

=

Do you want to allow the following program from an
unknown publisher to make changes to this computer?

Program name:  D\InstallInst(En)WAMS-850 Setup.msi

Publisher: Unknown
File origin: CO/DVD drive
() Show details Yes

. MNo

Change when these notifications appear

-




15 AMS-850 o] @ [
Installing AMS5-850 .l

AMS-B80 iz being installed.

Please wait...

< Back Hest =

(5) AMS-850 installation is complete, Click [Closel.
AMS-850 is registered in the Start menu. Then, the shortcut is created on the
desktop.

15 Ams-gs0 o] ® |5
Installation Complete [l

AMS-850 haz been successfully installed.

Click "Close" to exit.

Cancel < Back

* Make sure the software is installed by a user with administration privileges.
For details, consult your system administrator.



4.2 Uninstalling AMS-850
(1) From the [Start] menu, select [Settings] and then [Add/Remove Programs].
(2) Select AMS-850, and then click [Change/Remove(C)].

@'\F/"hj » Control Panel » Programs » Programs and Features

Control Panel Home .
Uninstall or change a program

View installed updates To uninstall a program, select it from the list and then click Uninstall, Change, or Repair.

'5' Turn Windows features on or

2t Organize *  Uninstall  Change  Repair == - i@l
Name Publisher : Installed On g
- AdobeR PDF Creation Add-On - Japanese Adobe Systems 2011/03/31
@ Adobe Flash Player 11 ActiveX Adobe Systems Incorporated 2013/06/12 =
A Adobe Flash Player 11 Plugin Adobe Systems Incorporated 2013/06/12
P8 Adobe Reader 9.5.0 - Japanese Adobe Systems Incorporated 2012/03/13
[m7 Akamai NetSession Interface Akamai Technologies, Inc 2012/06/22
[ AMS-850 Anritsu Meter Co., Ltd. 2013/07/19
(w77 AMS-800 AnritsuMeter 2012/07/05
[ AMS-100 AnritsuMeter 2013/03/11
EA ATI Catalyst Install Manager ATI Technologies, Inc. 2011/03/07
|_|Crystal Reports 2008 Runtime Business Objects 2011/03/31
[m%] Cadence License Manager 10.80 Cadence Design Systems 2011/03/31
Cadence SPB/OrCAD 16.3 Cadence Design Systems, Inc. 2011/03/31
[m5] CubePDF Utility 0.1.1 CubeSoft 2013/06/12 il
P : B - [T " o 3

‘. 3|  Anritsu Meter Co.,, Ltd. Product version: 21 Support link: http://www.anritsu-meter.com,
Help link: http://www.anritsu-me... Size: 101 MB

(3) Click [Yes (Y)] to remove AMS-850.

Programs and Features

l . Are you sure you want to uninstall AM5-8507

[] Inthe future, do not show me this dialog box ¥es ] [ Mo

% The saved data files will remain in their respective folders even after
AMS-850 is uninstalled.

-10-



5. Screen Configuration

5.1 Names and Functions of the Main Screen

AMS-850 - Am-0001.an3 = o=

Menu bar e pie i view Settings Communication Window Help

TOO].baI' —ﬁélﬁ mE%Dib?
B Am-0001.an3:1 =B = <

File nane An-0001
Frart cine 18/0%/01 12:00:00  Interval 1¥*  Hachine He. O
Chaonel displared 1 (0.17%

[T}
1M.Q

1559 f -\

140.0 }l'

Graph display mmf= 1 : —

o [ 1Y
\

§5.0Q

.0
!

e
1 — |
0.0
n.q 1r.a 35.3 58.% .4 55.0
(FE}

B Am-0001.an3:2 = |[= ][ ==

. File name fm-0001
Data display s Start time 17/03/01 12:00:00 Interval lsec MWachine No. 0

Sampleto. H:iM:3  leh.[%C]
0oono! 0o:00:00 2h.4
0ooooz 0o:00:01 2h.4
0opoo3 00:00:02 2h.4
000004 0o:00:03 25.4
0aooos 0o:00:04 2h.4
0o00oB 0o:00: 05 2h.4
g 0o:00:06 25.3
0opoos 0o:00:07 2h.3
0oooog 0o:00:03 2h.3
naoolo 0o:00:04 2h.3
poontl 0o:00=10 2h.3
Qooolz 0o=on=11 25.4
0aooli3 00:00:12 2h.5 -

m|

Menu bar: Allows you to set functions and perform measurements.

Toolbar: Contains the frequently used functions that have been turned into buttons.
Graph display: Displays measurement data as a graph.

Data display: Displays measurement data in list form.

-11-



5.2 Operation Method

<Operation with a mouse>

Clicking the left mouse button on an item in the menu bar or toolbar allows you to
select the item.

In the data display or graph display screen, furthermore, you can use the mouse to
scroll the screen.

<Operation from the keyboard>
You can use the keyboard to select items in the menu bar or toolbar as you do with
the mouse.
The English letters corresponding to menu items have an underscored letter, as in
File, thus can be typed in using the keyboard to select a menu or perform an
operation, as shown below.

* Menu bar: ALT (GRPH) + English letter (e.g., File, Communication)
+ Pulldown menu: English letter (e.g., Open, Print)

+ TAB key: Moves to the subsequent input point (for example, between items in a
dialog box).

<Entering alphanumeric characters>
Numbers must be entered in half-width characters when setting up graphs
and other performing other operations.
You can use either half-width or full-width characters for file names and
notes.
Do not use special characters for file names.

-12-



6. Using the Software

6.1 Setting the Communication Port
® In the Communication menu, select the port on your computer that is to be used

for communication with the measuring instrument.

When you are using USB, select USB here.

Communication

Input data

Real Measzurement

Remuote setting
Quit communication

5TART Command
EMD Command

Window Help

Selection of Senal Port
COM: |[7] COM1 ~

Cancel ‘

X5

USB()

v Selection of Serial Port..,

% If you do not know which serial port number to use or you wish to check
whether the USB cable is connected, follow the procedure below:

% FL-2000 cannot select USB communication.

(1) From the Start menu of Windows, choose Settings and then Control Panel.
(2) In Control Panel, choose System and open Device Manager. Then, check the

following:

* For RS-232C communication, check the COM number of the port.
+ For USB communication, check to see that “DCUSB” is shown in
Universal Serial Bus controllers. If it is not shown, temporarily

remove the USB cable and then reinsert.

3 @ Event Viewer
> 3] Shared Folders
> &% Local Users and Groups
3 Eé‘z‘:lil Performance
iy Device Manager
4 =5 Storage
=% Disk Management
= Services and Applications

b ﬂ Mice and cther pointing devices

o I Monitors

aOther cle

T Ports (COM & LPT)

Y5 Cammunications Port (COMI)

- ? Communications Part (COM2)

» L FIOCESSOrS

b |42 Security Devices

b -#% Sound, videc and game controllers

> Systern devices
> g Universal Serial Bus controllers

_';l_,- Computer Management E@
File  Action Yiew Help
o | HEE HE & 2 %S
A4 Computer Management (Local ey DVD/CD-ROM drives * | Actions
a [f} System Tools b IIEJE ATA/ATAPI controllers Device Manager -
> (B Task Scheduler » D Keyboards
More Actions »

m

-1 3-



6.2 Making or Changing Settings on the Measuring Instrument

(1) Connect the measuring instrument to the computer with the communication

cable, and turn on the power to the measuring instrument.

(2) Choose Remote setting from the Communication menu.

Remote setting @

Date and time 00/01/00 00:00:00 Interval 1 sec Machine No. O
Channel used 1 ({0.lDeg C)

Amount of free memory 50000

Set| Setting the date and time |00 Year |07 Month [0 Day WHour 00 Minutes 00 Second

A —
Set | Fonwarding the date and time of PC
Interval
— e i
B Setting intervals & |ET Mintes 1 Second

D

|0 ticrozecond
C — St Setting the channel used
Range
b St | Switch of range
J % D1DegC
" 1DeqC

E —

| — Set| Setting the machine 0

|0 Millizecond

Clearing memary space

A. Setting the clock
This value is fixed at “00 (year) 01 (month) 01 (day) 00 (hour) 00 (minutes)
00 (seconds).” It cannot be changed.

B. Setting measurement intervals
This value is fixed at “1 second.” It cannot be changed.

C. Setting the channels used for measurement
This value is fixed at “Channel 1 temperature.” It cannot be changed.

D. Setting resolutions
This value is fixed at “0.1°C.” It cannot be changed.

E. Clearing memory
Clears the data stored in the internal memory of the FL-2000.

Set| Clearng memony space

F. Setting machine No.
This value is fixed at “0.” It cannot be changed.

-14-



6.3 Downloading Data from the Measuring Instrument
Download the data saved in the measuring instrument into your computer to
create a file.
The data in the measuring instrument is separated in block units, and one file is
created for each block.
(1) Connect the measuring instrument and computer with the communication
cable, and turn on the power to the measuring instrument.
(2) Choose Input data from the Communication menu.
(3) Specify the destination folder into which data is to be saved, and click OK.

Browse for Folder @

PR Desktop
s 'E'h! Metwork
» [ Libraries
A gijutu
a (M Computer
3 ‘;, Local Disk (C:)
» g DVD RW Drive {D:)
> Removable Disk (E:)

[ Ok ][ Cancel ]

During communication, a transfer bar is displayed as shown below, allowing
you to confirm the progress of data transfer. Pressing Interruption here causes
the communication to stop, and the data currently being transferred or not yet
transferred is not saved in the PC.

Input data

| | | | |
I 30000 al000 20000 120000

% Do not press any keys on the measuring instrument during
communication, as this will terminate transfer or cause a malfunction.

#¢  Since the data in the measuring instrument is retained even after you
selected to run Data Input, if a communication error, etc. occurs during
communication, reselect Data Input.

_1 5-



When Data Input finishes and all data has been transferred, a newly created
data file is displayed.

Data input @

[0] Data file (Am-0001.an3) was successfully written,

(a) File names
The files are named “Am-**** an3”.

The **** part in the file name denotes a number assigned for each
directory from 0001 to 9999. Even if a file is deleted, all other file numbers
remain unchanged.

For example, if when files up to the number 9999 are saved on the hard
disk, files from 0001 to 9998 are deleted, the file with the number 9999
remains intact. In this case, because the file with the largest number
(9999) remains saved, no more data can be saved in the directory where
this file exists.

If new data needs to be stored in this directory, rename the file or take
other appropriate measures.

Example: Change the name “Am-9999.an3” to “Am-0001.an3.”

(b) File size
The file size is comprised of the following.

File size = (header part) + (data part) x (amount of data)

+ Header part (information on measurement) = 1,024 bytes
+ Data part (per data on each channel) = 2 bytes

Example 1: If the data size is 3 KB
File size = 1,024 + 2 x 3,000
= 17,024 bytes
= approx. 7 KB

Example 2: If the data size is 120 KB
File size = 1,024 + 2 x 120,000
= 241,024 bytes
= approx. 240 KB

-16-



6.4 Real Measurement Method
This method displays a graph during measurement. The data is saved to a file.
(1) Connect the measuring instrument to the computer with a communication

cable, and turn on the power to the measuring instrument.

(2) Choose Set Real-time data autosaving from the Settings menu.

3

(4)

2 During real measurement, the data is saved at predetermined intervals.
Consequently, even if the power to the PC is suddenly shut down, the data
saved up to this point exists as a backup file. The file can be opened in
AMS-850 by changing its extension (dat) to the one that corresponds to the
measuring instrument you used for measurement (an3).

Automatic save setting @

W Adtomatic save setting

Save jnterval: ||37 Hour @ Minutes

Destination to save: |E:\Usels'\L|sers'\D esktop

(]9 | Cancel |

@ Select to enable or disable automatic saving.
@ Set the interval in which you wish data to be automatically saved.

The time interval can be set in the range 1 minute to 23 hours 59
minutes.

@ Specify the destination folder into which to save.
The names of the files created by autosaving are named according to
date with the extension “dat” added.
Example:C:¥Program Files¥Anritsu-Meter¥AMS-850¥DATA¥050401.dat
April 1, 2005
Choose Real Measurement from the Communication menu.

.,
Real meazurement @

-,

191 Do you wish to save the measurement data?

Mo Cancel

To create a file, click Yes and specify the destination folder into which to save.
The files are named “Am-3% 3% 3% 3% .an3” (%% 3% 3% denotes file numbers 0001
to 9999). If the amount of data in a file exceeds the limit, the file number is
incremented by 1 and the next data that follows is saved to a new file.

2% The measurement underway is temporarily halted when a new file is

created, thus data for several intervals during which time measurement is
halted may not be acquired.
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The amount of data that can be saved to one file will be 120,000 dates.
% If measurement is taken over a long time and disk space runs out,
measurement is aborted and a message is displayed on the screen.

(5) Set the type of graph you wish to be displayed.

Graphical representation Setting @

File: rarme Arm-0001
Start time 0007407 00:00:00 Interval 1 zec Machine Mo, 0
Channel displaved 1 (0.lDeg C)

The gample Mo, displayed first; ] [ 1 — 0]
The nuniber of zamples displayed:  |G00 [ 1 ~ 120000]
Chatnel dizplayed: W 1ch [ o o o u
r o o o o u
r o o o o u
r o o | | o
Upper limit of temperature indication: [260.0 DegC [ -199.0 ~ 2000.0 ]
Lowser limit of temperature indication; |20.0 DegC [ -200.0 = 1999.0 ]
Upper limit of voltage indication: 20.000 W [ -19.990 ~ 20.000]
Loweer limit of waltage indication: 20000y [ -20.000 ~ 19.990]
Dizplay of elapsed time: + Relative time

" Absolute tine [ 1871~ 2037year]

Cancel |

@D Set intervals on the horizontal axis according to the number of displayed
samples.

The number of samples displayed:  |600 [ 1 ~ 20000]

To find the number of samples from the time
Number of samples = maximum time on the horizontal axis (in
seconds)/ interval (in seconds)

Example: To calculate the number of samples, in order to display the
data (measured at 1-second intervals) for 60 minutes
Number of samples = 60 minutes x 60 (seconds) x 1 (second)
= 3600

@ Select the channels whose data you wish to be graphically displayed.
“Channel 1 temperature” is the only available choice on the FL-2000.

Channel displayed: W 1ch [ [ [ [ [
[ n n [ n n
[ n n [ n n
[ n n [ n n
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@ Set the upper-limit and lower-limit display values to set up the vertical

axis.

You cannot set the upper or lower voltage display limit on FL-2000.
pper lirmit of temperature indication: IW DegC [ -138.0 w 2000.0 ]
Lowser limit of temperature indication: IW DegC [ -200.0 - 1983.0 ]
Ipper limit of voltage indication: IW b [ -159.990 ~ 20.000]
Lowwer limit of voltage indication: IW W [ -20.000 ~ 15,930]

@ When all parameters have been set, click OK.
Measurement will start.
The time is fixed at “00 (year) 01 (month) 01 (day) 00 (hour) 00 (minutes)
00 (seconds).” It cannot be changed.

AMS-850 - [Am-0001.an3] =N EeR(E<)

Bff File Edit View Settings Communication Window Help NE

= BESkOBR0LKE 2

File name Am-0001
Start time 00/01/01 00:00:00 Interval 1 sec  Machine No. 0

Channel displayed 1 (0.lDeg C)
(Deg C) -

170.0

155.0 /\
140.0 / \
125.0 /
110.0 /
95.0 /
80.0 / \
65.0 /

//

50.0
35.0 _J_/,
20.0
0.0 17.6 35.2 52.8 70.4 88.0

(Second)

To finish real measurement, choose Quit communication from the
Communication menu.

® Viewing the data preceding the time currently displayed on the screen
during measurement

@O Choose Scroll the graph from the View menu.

@ Drag the gauge and move the mouse left or right.
This will move the horizontal axis of the graph to the desired point.

¢ Real Measurement is dependent on the performance of your PC.
Measurement delays or errors may occur, particularly when other software
is running.
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6.5 Loading and Displaying an Existing File
Open one of the files that have already been saved by AMS-850 and display it
graphically or as a data list.
(D Choose Open from the File menu.

Open &
Laok in: |DATA
MName | Size | File type | Updated day... | Finding
R Am-0001 28KB  AMS-850 Data File 2002/03/261...

4 T 3
File hame: | Open |
Files of type: |AMS—85EI Data File(* an3) j Cancel

@ Specify the file you wish to open and click Open.

¢ Check to see that the file name you have selected is shown in the file
name column before you click Open.

AMS-850 - [Am-0001.an3] [E=5EeR ()

Bl File Edit View Settings Communication Window Help NER

= BSk DEH=0LE?

File name 2m-0001
Start time 00/01/01 00:00:00 Interval 1 sec Machine No. 0

Channel displayed 1 (0.1lDeg C)
(Deg C) -
170.0

155.0 /\
140.0

125.0 /
110.0 / \
95.0 /

80.0 / \
65.0 /

50.0 /
35.0

— ]

20.0

0.0 17.6 35.2 52.8 70.4 88.0
(Second)
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® You can use the toolbar to switch between graph display and data display.
N\,

-5 Sl

Window Help

= B SR IO ZL|E]?

AMS-850 - Am-0001

File Edit View Settings Communicatif

<To display a graph and data simultaneously>
* While a graph is active, choose New Window from the Window menu.
Two instances of the same graph will be opened, so use the toolbar to
change one of the two graphs to data display.

AMS-850 - Am-0001.an3 [E=H =N 5

File Edit View Settings Cemmunication Window Help

F ®BEkTEBO I~ 7

5 Am-0001.an3:1 == == | & Am-0001.an3:2 (== ]rz]
File name Am-0001
Start time 00/01/01 00:00:00 Interval 1 sec
SampleNo. H: M: 35 1lch. [C]
Fila name am-0001
Stact cime 83/01/81 00:03:00 Intesval 1 sec  Mashina Na.
. N (tag g haEsel dlimlagad | 1 (2.1feg o
000001  00:00:00 25.4 - )
000002  00:00:01 25.4 e [y
000003  00:00:02 25.4 = f.'
000004  00:00:03 25.4 E 1400
000005  00:00:04 25.4 1250 J'I
000006  00:00:05 25.4 [
000007 00:00:06 25.3 e ,,l \
000008 00:00:07 25.3 55
000009  00:00:08 25.3 oo J‘ \
000010 00:00:09 25.3 ‘\
000011 00:00:10 25.3 g0
000012 00:00:11 25.4 0.1
000013  00:00:12 25.5 .
000014  00:00:13 25.7 = — I
000015 00:00:14 26.0 = nﬂ.ﬂ 17.€ 5.2 52.8 70.4 8.0
000016  00:00:15 26.3 (sacana)
000017  00:00:16 26.6
000018 00:00:17 26.9
000019 00:00:18 27.0
000020 00:00:19 27.2
000021 00:00:20 27.3
000022 00:00:21 27.3 -

X If you wish to change the display range of the graph or the line color or

line type of the graph, refer to Section 6.7, “Graph Display.”

% The time is fixed at “00 (year) 01 (month) 01 (day) 00 (hour) 00
(minutes) 00 (seconds).” It cannot be changed.
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6.6 Printing Graphs and Data
You can print the graph or data or remarks being displayed on the screen via a
printer.
(D Activate the target you wish to print (e.g., graph or data).
* Note that multiple graphs or sets of data displayed on the screen are only
printable singularly.

@ Choose Print Setup from the File menu, and then set up your printer.

[ Print @-‘

Printer

Mame: Microzoft XPS Document Writer Properties..
Status: Ready

Type: Microzoft XPS Document Writer

‘Where: HPSPort:

Comment: [~ Print to file

Frint range Ciopies

(o Al Mumber of copies: 1 _|:|
(~ Fages  from: |1 o

o 111 22 3l T

Ok I Cancel |

@ In the File menu, select the type of graph to be printed. Select color or black
and white (depending on printer type).
Some monochrome-only printers cannot print lightly colored lines. In that
case, select to black and white.

Edit View Settings Cemmunication  Window
Open... Ctrl+0

Print... Ctrl+P
Print Preview

Print Setup...

Output the graph in Black and White
v Output the graph in Color

1 Chlsers\.. ADATANVAmM-0001
2 EASAMPLE_DATAYAmM-0001
3 Am-0001

Create Text file

Exit

@ Choose Print from the File menu, and then click OK to print.

-2 2-



6.7 Graph Display

Measurement information

[

AMS-850 - [Am-0001.2n3] / EI@

B File Edit View Settings Communicstion Window Help mNER

= B SkDNBAR0O0LHE?T

File name Am-0001

Start time 00/01/01 00:00:00 Interval 1 sec Machine No. 0
Channel displaved 1 (0.1lDeg C)

(Deg C -

170.0

155.0 /\
140.0

125.0

110.0 / \
95.0

80.0 / \
65.0 /

50.0 /
35.0

B ——

20.0

0.0 17.6 35.2 52.8 70.4 88.0
(Second)

A. Setting the display range
® Activate the graph and choose Set the graphical representation from the

Settings menu.
Graphical representation Setting @

File: name Arn-0001
Start time 00/07/01 00:00:00 Interval 1 sec Machine No. 0

Channel displayed 1 (0.1Deg C)

The sample Mo. displayed first: 1 00:00:00 [ 1 - ga]
The number of samples displayed: |28 000127 [ 1 ~ 120000]
Channel displayed: v 1ch [ u [ I I

u I o u o o

m m r m u u

m m r m u u
Lipper limit of terperature indication; |170.0 DegC [ -199.0 -~ 2000.0 ]
Lowwer limit of temperature indication: |20.0 DegC [ -200.0 = 1999.0 ]
|Upper limit of voltage indication: 20.000 Y [ -19.990 ~ 20.000]
Loweer limit of voltage indication: 20000 [ -20.000 ~ 19.990]
Dizplay of elapsed time: ' Relative time

™ Abzolute time [ 1871 - 2037year]

Cancel
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(a) Changing the scale of the horizontal axis

The zample Mo. dizplayed first; 1 00:00:00
The number of zamples displayed: |98 00:01:27

[
[

o
o

120000]

D Set First Sample No. to specify the minimum value on the

horizontal axis.

@ Set Samples to specify the measurement data sequence number on

the horizontal axis.

* Clicking the time displayed to the right of the input column allows you
to edit the approximate value for the start or the end time.

(b) Changing the scale of the vertical axis

Upper limit of temperature indication: |170.0 DegC [
Lower limit of temperature indication: |20.0 DegC [
Lpper limit of voltage indication: 20.000 W [

Lawer lirit of voltage indication: -20.000 W [

salrle

—-200.

0

0

-15.930

-20.000

i

i

i

2000.0 ]
1999.0 ]
20.000]

159.990]

® Set the upper-limit and lower-limit display values to specify the

display range on the vertical axis.

For the temperature display range, set Upper Range (Temp.) and

Lower Range (Temp.).

(c) Setting to show or hide channels

Channel displayed: W 1ch [ [ [ [ [

B B B o B o

[ [ [ B [ B

[ [ [ B [ B

® Choose to show or hide channels.
Do not start measurement before select channels.
(d) Selecting time display
Digplay of elapzed time: {* Relative time

{7 Abzolute time [ 81 - 2037year]

® Select the format of time in which you wish the time to be displayed.

Relative time indicates the lapsed time

measurement.

from start of

The FL-2000 always displays the absolute time from “00 (year) 01

(month) 01 (day) 00:00:00.”
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B. Setting line colors and line types
Graphs can be drawn with different line colors or different line types for each
channel.

(D Choose Set the graph Color and Line type from the Settings menu.

Graph Color and Line type Setting @

File narme Arm-0001

2ch | ach | 4eh | S | eh | 7eh | men |

sch | 1och | e | 12 | 13en | taen | 1seh | 1eck |

17ch | 13ch | tsch | 20ch | 2teh | 22k | 23k | 24cn |

Initialization aK Cancel

@ Click the button for the channel whose line colors or line types you wish to
change.

[ Color and Line type Setting @

Bazic colors:

Hl AR NN

EEEEN
HEEEN I
HEEENT
EEENEN

LCustom colars:

Marker  [yone -

Define Cugtom Colors »3 |

] | Cancel |

@ Select your desired color from Basic Colors or Custom Colors.
@ For the line type, select solid line or broken line.
® For the marker, select the one desired.

_2 5-



C. Enlarged display
(a) Enlarging

D Choose Enlarge the selection from the View menu.

@ Hold down the left mouse button on number O or @ of the red
magnification bar while moving the mouse, and the magnification bar
will move. Specify the range of the graph you wish to be enlarged. (You
also can use the arrow keys to move the magnification bar.)

B AMS-850 - [Am-0001.an3] =) [ )
[} File Edit View Settings Communication Window Help _ =]
= = b~ %
(=]
gllE name Aﬂgﬂgglnl o00i00 T - achine fo. 0 File name Am-0001
tart time 00/01/01 00:00:00 nterva sec  Machine No. O Linel 00:00:41 Line2  00:01:19

o ) Channel displayed _1 (0.1lDeg C) 1eh: 157.6 ¢ 1ch: s5.2 ¢
eq C h: 7. h: .8

170.0

155.0
140.0 /
125.0

110.0 / \
95.0

50.0 /
35.0 -,
I S
20.0
0.0 17.6 2 52.8 0.4 G, 880
“' (Second)

(D Press the right mouse button and then click Zoom.
The range of the graph specified by the magnification bars O and @
will be enlarged.
In addition, data in positions @O and @ are displayed

simultaneously.
AMS-850 - [Am-0001.an3] = -2 )
@E\Ie Edit View Settings Communication Window Help =[5 %
& DE®0 I~ E| %

File name Zm-0001
Start time 00/01/01 00:00:00 Interval 1 sec Machine No. 0
Channel displayed _1 (0.1Deg C)
(Deg C)
170.0

155.0 \
140.0 \

4z2.0 49.4 56.8 64.2 71.8 75.0
{Second)
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(b) To reverse the enlarged display
® Choose Restore the display range from the View menu.
The enlarged range of the graph will be returned to its original size.

D. Merging two graphs

You can merge two different files into a single file for graph display.

D Open the first file (see Section 8.5).

@ Choose Merge files from the Edit menu, select the second file in it, and
then click File Open.

AMS-850 - [Am-0001.an3] =N ol ==

@Eile Edit View Settings Communication Window Help — |[ & =

F BSk DB8BO L 2

File name Am—0001
Stars time 12/02/01 12:00:00 Imterval 1 ==c  Machine No. 0
Channel di=played 1 (0.10=g C}

File name Am—0008
Stars time 12/02/01 12:00:00 Imterval 1 ==c  Machine No. 0
Channel di=played 1 (0.10=g C}
[D=g T} -
170.0

A
A

o.o0 18.& a7r.2 55.8 74.4 g3.0

(3econd)

* Note that the following files cannot be merged.
Files derived from manual measurement
Data files derived from measurement with a 1999.9 mV voltage range
Combination of files in different units of temperature, °C and °F
Combination of files in different time interval, 1 or more second and less
than 1 second.
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6.8 Data Display
AMS-850 - [Am-0001.an3] =2 EoN =

@Eile Edit View Settings Communication Window Help =[5

F B S DE®0O ey FE

File name Am-0001
Start time 00/01/01 00:00:00 Interval 1 szec Machine No. 0

SampleNo. H: M: 5 1ch. [C]

000001 00:00:00 ]
0ooooz 00:00:01 ]
000003 00:00:02 ]
000004 00:00:03 ]
000005 00:00:04 ]
000004 00:00:05 ]
0oooo7T 00:00:08 ]
000008 00:00:07 ]
00o0o0os 00:00:08 ]
000010 00:00:08 25.
]
]
]
5
[
[
[
[

m

000011 00:00:10
000012 00:00:11
000013 00:00:12

R LS5 SV L T L T L T T L B e L

000014 00:00:13

000015 00:00:14 .0
000014 00:00:15 .3
000017 00:00:16 .6

9

000018 00:00:17 26.

A. Setting the format for time in which you wish the time to be
displayed
D Choose Set the Data display from the Settings menu.

Set the data display @

File name Am-0001
Start time 0040701 00:00:00 Interval 1 sec Machine No. 0
Channel displayed 1 ({0.1Deg C)

Dizplay of elapsed time: & Relative time

" Abzolute tme [ 1971 ~ 2037pean]

Cancel

@ Select the format of time in which you wish the time to be displayed.
+ Relative time indicates the lapsed time from start of measurement.
3% The FL-2000 always displays the absolute time from “00 (year) 01
(month) 01 (day) 00:00:00.”
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6.9 Using Data in Spreadsheet Software
The data files created by AMS-850 can be converted into CSV files for use in
Excel or other spreadsheet software.

(1) Choose Create Text file from the File menu.

Open &
Look in: ‘DATA
MName | Size | File type | Updated day... | Finding

i=1 Am-0007 2okE  AMES-850 Data File 20020326 1...

4 m

File name: Am-0001.an3 Open

p
Files of type: |AMS—BED Data File(*an3) j Cancel

(2) Specify the file you wish to convert and click Open.
The converted file is created in the same directory as its source file.
This file is named after the source file by changing its extension to “.csv.”

Example:
Source file C¥Data¥Am-0001.an3
Converted file C¥Data¥Am-0001.csv

-2 9-



(3) Set the format in which you wish a text file to be saved.

Create text file @

File: namme Am-0007
Start time 00A01/00 00:00:00 Interval 1 zec Machine Mo, 0
Channel displayed 1 (0.1Deg C)

The zample Mo. displayed first:

1
The number of samples displayed: |99 [ 1 ~ 83 ]
’17

Step:

Digplaying the time
. . . N
Displaying the time: one
+ Relative time

(" Absolute time [ 1971/01/01 00:00:00
20372431 235359 ]

Cancel

D Set the sequence number of the data from which you wish a text file to be
created.

The zample Mo, displayed firgt: 1 [ 1 — 88 ]

@ Set the number of data items present in one file.

The number of data items actually created is
(Number of data items) = number of displayed data items / number of steps

The nurnber of samples displayed: |33 [ 1 — 88 ]

@ To create a text file by interleaving or “thinning out” the source data file,
you need to set the increment amount.
* Depending on the spreadsheet software used, the number of data items
that can be loaded is limited. If the source file contains a large amount
of data, interleave it following the above procedure or split the file.

Step: 1 [ 1 ~ 88 ]
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@ Select the format of time in which you wish the time to be displayed
when a text file is created.

Digplaying the time

. . . M
Dizplaying the time: one

* Relative time

£ Absgolute time [ 1971/0101 00:00:00
~A0FTA 243 235359 ]

* Relative time indicates the lapsed time from start of measurement.
% The FL-2000 always displays the absolute time from “00 (year) 01
(month) 01 (day) 00:00:00.”

* When Relative time is selected, the time can only be displayed in the
range 00:00:00 to 23:59:59 (hours:minutes:seconds). Please note that the
data collected during 24 hours or longer is displayed in the above range
of time repeatedly.

(® Double-clicking a text file with the mouse launches spreadsheet
software.
If you are using Excel, the file will be displayed in a manner similar to
the samples shown below. You can create a graph from the file by making
use of the functions of Excel.

<Time display: Relative time>

A B
I File name  Arm—0001

N Start time 0 Year 1 Maonth 1 Day
4 0 Hour 0 Minutes 0 Second
F'I
S Lte real 0 Hour 0 Minutes 1 Second
0 Millise co nd 0 Microsecond
= Wachine Mo 0

Filz name  Am—0001
Start time 0001701 Q00000 Interval 1Sec Machine Mo

Sample M H MS  1ch[Deg C] 180
1 000000 25 4 160
2 00000 25 4 140
3 000002 25 4 120
4 000003 25 4 100
5 000004 254 80
6 000005 254 o0
ER e et e ol -] AE T 40
20
0 _
00:00:00 00:00:20 00:00:40 00:01:00 00:01:20

_3 1-



6.10 Pasting Data into a Document File
(D Launch AMS-850 and open a data file (see Section 8.5).

@ Choose Copy from the Edit menu. The screen data will be copied to the
clipboard.

® Open a document file created in Word, etc.

@ Move the mouse to your desired position in the document and paste the
copied data at that position.

6.11 Attaching a Remark to Graphs or Data
A. How to create a remark
@D Choose Edit remark from the Edit menu.

Open =]
Look jn: |DATA
MName | Size | File type | Updated day... | Finding

=} Am-0001 Z28KE  AMS-350 Data File 2002/03/261...

4

n 3

File name: |Am—DDD1.an3 Open |
Files of type: |AMS—ESU Data File(*an3) j Cancel

@ Specify a file name and click Open.

(@ Enter a remark representing the content of data recorded in the file or the
conditions under which data was recorded.

Edit remark

=

File name Em-0001 |3—:I-1:le dara-1

Start time 02/03/26 11:459:05 Interval 1 sec Machine No. 0

Channel displayed 1 2 3 4

5 & (0.1Deg C)
L~
/ Bemark sample data-1
chl:sampling No.l
chi:za .2
.3
.4
.5
ché:sampling No.é
Cancel
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AMS-850 - Am-0001

File

~u

=

Edit  View Settings Communication  Window Help

BSL OB L IE T

] Am-0001:1 [E=R[E=R>T)

il Am-0001:2

===
[=

=)
=

=]
S

[SI=I=r=
[SI=I=]

(==

=1

3 B3 B3 BRI R B3 R R B3 B3 R R ORI B3 R) BR) B3 B3 RD
303 G G R ORD ORI B3 R ORI R R R R R G D G G

(SR

O

=1

i

~l Mmoo W

e

WLy

[STNE 8]

mom oo O

O mom

3 B3 BRI B3 R ORI ORI B3 BRI B3 R R R R BRI BR) BRI BRI BRI
303 L G BRI R R ORI ORI ORI ORI G0 L G0 L Lo

3R

B. How to check details of the remark

® Choose Display Remark from the View menu.

AMS-850 - [Am-0001]
@Eile Edit View 5Settings Communication Window Help

~u

=

BSRIDB=O ~E %

=N HoR =<

File name Am-0001 sample data-1

Start time 02/03/26 11:45:05 Interval 1 sec

Channel displayed 1 2 3 4 5 &

(0.1Deg C)

Machine No.

o

—-——— Remark —-—

sample data-1
chl:=sampling No.l
ch2:=zampling No.2
ch3:sampling No.3
ch4:sampling No.4
ch5:=sampling No.5
ché:sampling No.&
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7. Version Information
Choosing About AMS-850 from the Help menu allows you to check which version of

AMS-850 is installed on your computer.
Note that the software version is subject to change without notice.

About AMS-850 =

-

COMPACT THERMO LOGGER

||
@ Ak S5-850 Version 2.0

Copyright [C] 1993-2011 Anritzu-k eter Cao., Ltd.

Fleaze naote that reproduction af materials
exceeding the permitted range of uze specified in
the contract and distnbution of the replica are
prahibited.

Application model;

A-7002 AM-7052 Ak-7102 AM-7012
AM-TOE2 AM-7112

A-8000 AM-2100 Abd-8050 AM-5150
A0-80710 AM-2110 Ak-8060 AM-E1E0
AM-3001 AM-8107 AM-3051 AM-8151
Ak-B0171 AM-81171 AM-B0ET AM-3161
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8. Error Messages

The following presents typical error messages output in this software application.
If one of these error messages is displayed, a handling error or problem on your
PC or equipment might have occurred.
Carefully read this manual for details on how to solve the problem. If the problem
persists, contact Anritsu Meter.
(1) Information displayed when the END command is executed
This information is displayed when [END command (E)] is executed from the
[Communication (C)] menu. The FL-2000 accepts the command without any
problems.

End Command @

f B This command is invalid for the main unit (measuring instrument) in

L 1 ) Sleep Mode or High Speed Interval.

(2) AM-9999 already exists in data storage location
Change the storage location for the measurement data by creating a new
folder or specifying a different location.

AMS-850 ==

The saved file name exceeds "AM-9999",
! % Specify another folder.

(3) If the value you have entered is incorrect
This error might occur when the input range is exceeded, or when an
unrecognizable character is entered for graph display. Check the values and
characters entered.

AMS-850 (3]

! 1 The input value is invalid.
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(4) If the measuring instrument cannot be communicated with
Confirm the following: FL-2000 is powered on; communication cables are
properly connected; and communication ports are correctly set.

AMS-850 (23]

Infarmation cannot be acquired from Compact Thermo Logger or Data
l . Collector.

(5) If the measuring instrument is not connected to your PC
Check whether the communication port on your PC is set to USB, or whether
there are any problems with the communication port settings.

AMS-850 ==

l 1 Failed to switch COM port.

(6) When [Data input (D] is executed from [Communication (C)] menu.
Confirm the following: communication cables are properly connected; and
communication ports are correctly set.

AMS5-350 @

l " Compact Thermo Logger or Data Collector contains no data.

(7) If an invalid value is entered on the FL-2000
This message is displayed when a setting that is not available on the FL-2000
is entered or selected in [Remote setting (R)] in the [Communication (C)]
menu. Check the values that were selected or entered.

AMS-850 (25w

Information cannot be sent to Compact Thermo Logger or Data
! . Collector.
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9. Command List

9.1 Explanation of the Menu Bar
<File>

® Open
Opens a data file.

® Print
Prints graph display, data display, or remarks via printer.

@ Print Preview
Previews the print data.

@ Print Setup
Sets up a printer.

® Output the graph in Black and White
Selects printer output mode for a graph so that the graph will be printed in
black and white.

® Output the graph in Color
Selects printer output mode for a graph so that the graph will be printed
using color.

@ Create Text file
Converts a data file into text format.

Exit (End of Application)
Quits AMS-850.

<Edit>

O Copy
Copies graph display, data display, or remarks to the clipboard.

® Edit remark
Attaches a remark to graphs or data.

® Merge files
Combines graphs in two data files into a single graph for display on the
screen.

<View>
D Enlarge the Select
Enlarges the selected range of a displayed graph.
® Scroll the graph
Scrolls the horizontal axis of a graph during real measurement.
® Restore the display range
Reverses the enlarged range of a graph to its original size.
@ Display the Graph
Displays measurement data graphically.
® Display the Data
Displays measurement data in list form.
® Display Remark
Displays information on a file, etc. as a remark or caption.
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<Settings>

(D Set the graphical representation
Sets the vertical and horizontal axes of a graph, and other parameters.

® Set the Data display
Sets the format of time displayed during data display.

@ Set the graph Color and Line type
Sets the line colors, line types, etc. of a graph.

@ Set Real-time data autosaving
Sets the destination folder in which the backup data for real measurement
is saved.

<Communication>
® Input Data
Downloads data from the measuring instrument into a PC.
® Real Measurement
Displays the data recorded in the measuring instrument graphically in
real time.
® Remote setting
Sets the clock and measurement conditions of the measuring instrument.
@ Quit communication
Stops communication.
® START Command
Sends the START command to the measuring instrument.
® END Command
Sends the END command to the measuring instrument.
@ USB
Sets the type of communication port interface to USB.
Serial Port COM1-6

Sets a communication port to one of the serial ports on a PC.

<Window>
® New Window
Opens a new graph or data list.
® Cascade
Displays open graphs or data lists in a cascade.
@ Tile Vertically
Tiles the graphs or data lists on the screen vertically, i.e., side by side.
@ Tile Horizontally
Tiles the graphs or data lists on the screen horizontally, i.e., one below
another.
® Arrange Icons
Arranges the icons representing displayed graphs or data lists in order.
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<Help>
©® About AMS-850

Shows the version information on AMS-850.

9.2 Explanation of the Toolbar
F o % T : %

O © 0w ®b6 0oEe © VL ®

o5

D Opens a data file.

@ Copies graphs or data to the clipboard.

(® Prints graphs or data.

@ Previews the data to be printed.

(® Tiles the windows horizontally, i.e., one below another.
©® Tiles the windows vertically, i.e., side by side.

(D Cascades windows in a neat stack with all windows visible.
Fills the whole screen with a window.

© Sets line colors and line types of a graph.

Displays measurement data graphically.

@ Displays measurement data in list form.

@ Displays version information.
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